Piip piip... raksutusta... raksutusta... numero 42…
No jopas. Näyttää siltä, että hullut robotit ovat taas vauhdissa! Ne ovat ottaneet vallan – ja kääntäneet tämän sivun omalle kielellesi. Robotit tarkoittavat tosiasiassa vain hyvää, ja niiden metallisydän sykkii lämpimänä. Ne haluavat auttaa! Kerro meille, miten hyvin robotit ovat hoitaneet homman. Käytä sivun alalaidan painikkeita. Siirry englanninkieliseen versioon

Korjaa ydintiedostovirheet WordPressissä

Kun olet vahvistanut, että sinulla on virhe WordPress -ydintiedostossa , voit yrittää palauttaa sivustosi toimintakuntoon.

WordPressiin liittyvän PHP -virheen ymmärtäminen

Jos edellisessä vianmäärityksessäsi paljastui PHP -virhe , käytä seuraavaa taulukkoa virheen ymmärtämiseen.

Virheen tyyppi Määritelmä ja seuraavat vaiheet
VIRHE Tämä on kohtalokas virhe, joka aiheuttaa komentosarjan lopettamisen. Nämä johtuvat tyypillisesti olemattoman objektin, kuten luokan tai toiminnon, kutsumisesta. Tämä voi usein ilmetä versioiden yhteensopimattomuudesta. Seuraavien vaiheiden tulisi olla WordPress -version, teemojen ja laajennusten päivittäminen.
E_VAROITUS Ajonaikainen varoitus ei aiheuta komentosarjan lopettamista. Nämä ovat mahdollisia ongelmia, jotka ilmenevät, mutta eivät lopeta PHP: n käsittelyä. Nämä voivat usein sisältää vanhentumisvaroituksia, mikä osoittaa, että koodisi saattaa käyttää PHP: n vanhentunutta versiota ja että se on päivitettävä. PHP -lokisi varoitus ei välttämättä liity ongelmaan.
E_PARSE Tämä on käännösajan jäsennysvirhe. Se viittaa tavallisesti PHP -syntaksivirheeseen, kuten puuttuvan puolipisteen;, sulkeiden () tai avaus- tai sulkuhakemiston kanssa{} , tai mikä tahansa määrä muita syntaksivirheitä. Sinun tulee tarkistaa virheilmoituksessa määritetty tiedosto ja viiva ja etsiä mahdollinen syntaksivirhe.
E_NOTICE Nämä ovat tyypillisesti PHP -virheitä, jotka eivät aiheuta komentosarjojen lopettamista. Ne osoittavat, että kyseessä voi olla ongelma, mutta se voi olla osa komentosarjan normaalia toimintaa. Yleinen syy on määrittelemättömän PHP -muuttujan käyttäminen. Huomautus PHP -lokeistasi ei välttämättä liity ongelmaan.

Päivitä WordPress uusimpaan versioon

WordPressin päivittäminen sen uusimpaan versioon päivittää tai korvaa kaikki ydintiedostot, mikä usein ratkaisee ydintiedostoihin liittyvät virheet. Jos virhe estää WordPress -koontinäytön käytön, sinun on ehkä päivitettävä ydintiedostot FTP: n kautta .

Päivitä WordPress -komponentit

Kun WordPress -versiosi, -teemasi tai -laajennuksesi päivitetään, niissä saattaa olla ristiriita muiden komponenttien kanssa, joita ei ole päivitetty. Muiden komponenttien päivittäminen voi palauttaa sivustosi. Päivitä sivustosi komponentti seuraavien ohjeiden mukaisesti:

Lisätietoja


Oliko tästä artikkelista hyötyä?
Kiitoksia palautteestasi. Jos haluat puhua asiakaspalveluedustajan kanssa, käytä yllä näkyvää puhelinnumeroa tai chat-vaihtoehtoa.
Kiva, että meistä oli apua. Voimmeko tehdä jotain muuta?
Olen pahoillani asiasta. Kerro meille, mikä on epäselvää tai miksi ratkaisu ei toiminut oman ongelmasi kohdalla.